
User Manual

Label Design and Printing Application

Version 1.0



Table of Contents 
Table of Contents .......................................................................................................................................... 2 

1. Introduction .............................................................................................................................................. 4 

1.1 About AmbirLabel ............................................................................................................................... 4 

1.2 System Requirements ......................................................................................................................... 4 

Windows ............................................................................................................................................... 4 

macOS ................................................................................................................................................... 4 

Hardware .............................................................................................................................................. 4 

2. Getting Started .......................................................................................................................................... 5 

2.1 Welcome Screen ................................................................................................................................. 5 

2.2 Creating Your First Label ..................................................................................................................... 5 

2.3 Interface Overview .............................................................................................................................. 6 

1. Menu Bar ........................................................................................................................................... 7 

2. Toolbar .............................................................................................................................................. 7 

3. Design Canvas ................................................................................................................................... 7 

4. Properties Panel ................................................................................................................................ 7 

3. Working with Label Objects ...................................................................................................................... 8 

3.1 Text Objects ........................................................................................................................................ 8 

Adding a Text Object ............................................................................................................................. 8 

Text Properties ...................................................................................................................................... 8 

3.2 Barcode Objects .................................................................................................................................. 9 

Supported Barcode Types ..................................................................................................................... 9 

Barcode Properties ............................................................................................................................... 9 

3.3 Image Objects ................................................................................................................................... 10 

Adding an Image ................................................................................................................................. 10 

3.4 Shape Objects ................................................................................................................................... 10 

Available Shapes ................................................................................................................................. 10 

Shape Properties ................................................................................................................................. 11 

3.5 Counter Objects ................................................................................................................................ 11 

Counter Properties .............................................................................................................................. 11 

3.6 Date/Time Objects ............................................................................................................................ 12 

Date/Time Properties.......................................................................................................................... 12 

3.7 Address Objects ................................................................................................................................ 12 



Address Fields ..................................................................................................................................... 13 

Address Features................................................................................................................................. 13 

4. Label Sizes ............................................................................................................................................... 14 

4.1 Built-in Label Sizes ............................................................................................................................. 14 

4.2 Creating Custom Sizes ....................................................................................................................... 14 

5. Data Merge and Batch Printing ............................................................................................................... 16 

5.1 Importing Data .................................................................................................................................. 16 

Supported Formats ............................................................................................................................. 16 

To import data: ................................................................................................................................... 16 

5.2 Importing Addresses ......................................................................................................................... 17 

5.3 Batch Printing .................................................................................................................................... 17 

6. Printing .................................................................................................................................................... 18 

6.1 Print Dialog ........................................................................................................................................ 18 

To print a label: ................................................................................................................................... 18 

6.2 Print Settings ..................................................................................................................................... 18 

6.3 Scaling Options .................................................................................................................................. 19 

7. Settings and Preferences ........................................................................................................................ 20 

7.1 General Settings ................................................................................................................................ 20 

Ruler Units ........................................................................................................................................... 20 

Language ............................................................................................................................................. 20 

Auto-Update ....................................................................................................................................... 20 

7.2 Grid Settings ...................................................................................................................................... 20 

Grid Size Presets .................................................................................................................................. 20 

8. Keyboard Shortcuts ................................................................................................................................. 21 

9. Troubleshooting ...................................................................................................................................... 22 

Printer Not Appearing in List .................................................................................................................. 22 

Label Prints Off-Center............................................................................................................................ 22 

Barcode Won’t Scan ................................................................................................................................ 22 

Data Import Fails ..................................................................................................................................... 22 

 
  



AmbirLabel User Manual 

Page 4 

1. Introduction 

1.1 About AmbirLabel 
AmbirLabel is a professional label design and printing application developed by Ambir Technology, Inc. It 
provides an intuitive interface for creating custom labels with various elements including text, barcodes, 
images, shapes, counters, date/time stamps, and address blocks. 

Key features include: 

• Label design canvas with rulers and grid 
• Support for multiple barcode formats (Code 128, QR Code, Data Matrix, and more) 
• Data merge capabilities for batch label printing 
• Built-in and custom label size options 
• Advanced print settings with scaling options 

1.2 System Requirements 

Windows 

• Windows 10 version 1903 (build 10.0.19041.0) or later 
• Windows 11 

macOS 

• macOS 15.0 (Sequoia) or later 

Hardware 

• Ambir label printer (recommended) 
• Minimum 4GB RAM 
• 100MB available disk space 
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2. Getting Started 

2.1 Welcome Screen 
When you launch AmbirLabel, you are greeted with the Welcome Screen. This screen provides quick 
access to common tasks: 

 

• New Label – Create a blank label with your choice of size 
• Open Existing – Browse and open previously saved label files 
• Recent Files – Quickly open labels you’ve worked on recently 

2.2 Creating Your First Label 
To create a new label: 

1. Click the New Label button on the Welcome Screen, or select File > New from the menu 
2. Select a label size from the dropdown menu in the right panel 
3. The design canvas will appear with your selected label size 
4. Add objects to your label using the Insert menu or toolbar buttons 
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2.3 Interface Overview 
The AmbirLabel interface consists of several key areas: 
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1. Menu Bar 

Provides access to all application functions organized in menus: File, Edit, Insert, Layout, View, and Help. 

2. Toolbar 

Quick access buttons for common operations like adding objects, zoom controls, and alignment tools. 

3. Design Canvas 

The main work area where you design your label. Features include: 

• Rulers along the top and left edges for measurement 
• Optional grid for precise object placement 
• Zoom controls to magnify or reduce the view 

4. Properties Panel 

Located on the right side, this panel displays properties for the selected object or label settings when no 
object is selected. 



AmbirLabel User Manual 

Page 8 

3. Working with Label Objects 
AmbirLabel supports several types of label objects. Each object type has specific properties that can be 
customized. 

3.1 Text Objects 
Text objects allow you to add and format text on your labels. 

Adding a Text Object 

1. Select Insert > Text from the menu, or click the Text button on the toolbar 
2. A new text object appears on the canvas 
3. Click on the object to select it and edit its properties in the right panel 

 

Text Properties 

Property Description 

Content The text to display 

Font Choose from available system fonts 
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Size Size of the text in points 

Style (B/I/U) Bold, Italic, and Underline styling options 

Alignment Left, Center, or Right alignment 

Letter Spacing Space between characters (Tight, Normal, Wide) 

 

3.2 Barcode Objects 
AmbirLabel supports a wide variety of 1D and 2D barcode formats. 

Supported Barcode Types 

Category Barcode Types 

1D Barcodes Code 128, Code 39, Code 93, EAN-13, EAN-8, UPC-A, UPC-E, ITF, Codabar 

2D Barcodes QR Code, Data Matrix, PDF417, Aztec 

 

 

Barcode Properties 
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Property Description 

Barcode Type Select the barcode format 

Data Source Manual entry or From Data (linked to imported file) 

Barcode Data The value to encode in the barcode 

Size Small, Medium, or Large 

Alignment Left, Center, or Right positioning 

 

3.3 Image Objects 
Add images such as logos or graphics to your labels. 

Adding an Image 

1. Select Insert > Image from the menu 
2. Browse to select an image file (PNG, JPG, BMP supported) 
3. The image appears on the canvas 
4. Drag corners to resize while maintaining aspect ratio 

 

3.4 Shape Objects 
Add geometric shapes to enhance your label design. 

Available Shapes 
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• Rectangle – With optional corner radius 
• Circle/Ellipse – Round shapes 
• Line – Straight lines for dividers or decoration 

 

Shape Properties 

Property Description 

Shape Type Rectangle, Circle, or Line 

Fill Color Interior color of the shape 

Stroke Color Border/outline color 

Stroke Width Thickness of the border 

 

3.5 Counter Objects 
Counter objects automatically increment numbers for sequential labeling, such as serial numbers or 
inventory tracking. 

Counter Properties 

Property Description 

Start Value The initial number 
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Increment Amount to add for each label 

Labels Per Number How many labels before incrementing 

Digit Format 01, 001, 0001, etc. (leading zeros) 

Prefix Text before the number (e.g., "SN-") 

Suffix Text after the number 

 

3.6 Date/Time Objects 
Add current or fixed date and time stamps to your labels. 

Date/Time Properties 

Property Description 

Date Format MM/DD/YYYY, DD/MM/YYYY, YYYY-MM-DD, etc. 

Include Time Add time to the stamp 

Time Format 12-hour or 24-hour format 

Use Current Always show current date/time when printing 

 

3.7 Address Objects 
Address objects provide formatted address display with barcode integration for mailing applications. 
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Address Fields 

• Name/Company 
• Address Line 1 
• Address Line 2 (optional) 
• City, State, ZIP 
• Country (optional) 

Address Features 

• Import addresses from CSV or Excel files 
• Configurable line spacing (Tight, Normal, Loose) 
• Font and formatting options 
• Rotation options (0°, 90°, 180°, 270°) 
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4. Label Sizes 

4.1 Built-in Label Sizes 
AmbirLabel includes over 30 pre-configured label sizes for common applications: 

Category Examples 

Address Labels 1.125" x 3.5", 1" x 2.625", 0.5" x 1.75" 

Shipping Labels 4" x 6", 2.25" x 4" 

File Folder 0.5625" x 3.4375" 

Name Badges 2.25" x 3.5" 

Return Address 0.75" x 2" 

 

4.2 Creating Custom Sizes 
Create custom label sizes for your specific needs: 

1. In the right panel, click the + Add button next to label sizes 
2. Enter a name for your custom size 
3. Set the width and height (in inches or millimeters) 
4. Optionally configure margins and corner radius 
5. Click Apply to save 
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5. Data Merge and Batch Printing 

5.1 Importing Data 
AmbirLabel can import data from CSV and Excel files for batch label printing. 

Supported Formats 

• CSV (.csv) – Comma-separated values 
• Excel (.xlsx) – Excel 2007 and later 
• Excel (.xls) – Excel 97-2003 

 

To import data: 

1. Create a label with text or barcode objects 
2. Select an object and choose From Data as the data source 
3. Click Import Data to select your data file 
4. Map your file columns to label fields 
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5.2 Importing Addresses 
The Address Import feature provides specialized handling for address data: 

1. Add an Address object to your label 
2. Click Import Addresses in the properties panel 
3. Select your CSV or Excel file 
4. Map columns to address fields (Name, Address, City, State, ZIP) 
5. Preview the imported addresses 
6. Select which addresses to print 

Tip: Your CSV file should include columns for Name, Address, City, State, and ZIP Code. Address Line 
2 and Country are optional. 

 

5.3 Batch Printing 
Print multiple labels with different data: 

1. Import your data file with address or other variable data 
2. Select the records you want to print 
3. The Copies field will automatically update to show the number of labels 
4. Click Print to print all labels in the batch 
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6. Printing 

6.1 Print Dialog 
AmbirLabel provides a custom print dialog with advanced options: 

 

To print a label: 

1. Click the Print button or select File > Print 
2. The Print Dialog appears with a live preview 
3. Select your Ambir printer from the dropdown 
4. Choose the page size 
5. Select orientation (Portrait or Landscape) 
6. Set the number of copies 
7. Choose a scaling option 
8. Click Print 

6.2 Print Settings 

Setting Description 

Printer Select from available Ambir printers 
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Paper Size Paper size supported by your printer 

Orientation Portrait (vertical) or Landscape (horizontal) 

Copies Number of labels to print 

 

6.3 Scaling Options 
Control how your label is sized when printed: 

Option Description 

Actual Size (100%) Print the label at its designed dimensions 

Fit to Printable Area Scale the label to fit within the page margins 

Custom % Specify a custom scale percentage (e.g., 50%, 150%) 

 

Note: The live preview shows exactly how your label will appear on the printed page, including 
position and scale. 
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7. Settings and Preferences 
Access settings by clicking the gear icon or selecting Tools > Settings. 

7.1 General Settings 

Ruler Units 

• English (Inches) – Display measurements in inches 
• Metric (Millimeters) – Display measurements in millimeters 

Language 

AmbirLabel supports multiple languages: 

• English 
• Spanish 
• French 
• German 
• Italian 

Auto-Update 

Enable or disable automatic checking for application updates. 

7.2 Grid Settings 

Setting Description 

Show Grid Display grid lines on the canvas 

Grid Size Spacing between grid lines 

Snap to Grid Objects align to grid intersections 

Snap to Snaplines Objects align to edges of other objects 

 

Grid Size Presets 

Quick buttons for common grid sizes: 0.05", 0.1", 0.125", 0.25", 0.5" 
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8. Keyboard Shortcuts 

Shortcut Action 

Ctrl + N New Label 

Ctrl + O Open Label 

Ctrl + S Save Label 

Ctrl + Shift + S Save As 

Ctrl + P Print 

Ctrl + Z Undo 

Ctrl + Y Redo 

Ctrl + X Cut 

Ctrl + C Copy 

Ctrl + V Paste 

Delete Delete Selected Object 

Ctrl + + Zoom In 

Ctrl + - Zoom Out 

Ctrl + 0 Zoom to Fit 
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9. Troubleshooting 

Printer Not Appearing in List 
Problem: Your Ambir printer doesn’t appear in the printer dropdown. 
Solution: 

• Ensure the printer is connected and powered on 
• Check that Ambir printer drivers are installed 
• Verify the printer appears in Windows/macOS printer settings 
• Restart the AmbirLabel application 

Label Prints Off-Center 
Problem: The label doesn’t print in the expected position on the page. 
Solution: 

• Check that the correct Page Size is selected in the Print Dialog 
• Verify the Orientation matches your label stock 
• Try using "Fit to Printable Area" scaling option 

Barcode Won’t Scan 
Problem: Printed barcode cannot be read by scanner. 
Solution: 

• Ensure barcode data is valid for the selected barcode type 
• Try increasing the barcode size (use Medium or Large) 
• Check that scaling is set to 100% or higher 
• Verify printer resolution is adequate (300 DPI recommended) 

Data Import Fails 
Problem: CSV or Excel file won’t import correctly. 
Solution: 

• Ensure the file has a header row with column names 
• Check that required columns exist (Name, Address, City, State, ZIP for addresses) 
• Verify the file is not open in another application 
• Try saving Excel files as CSV format 

Need More Help? Contact Ambir Technology Support at support@ambir.com or visit 
www.ambir.com for additional resources. 

 




